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Appendix 1: Supplementary 3D-pdf protocol
Version 10-09
Publishing three-dimensional structural information through Adobe's Portable Document For-
mat (pdf ); A Protocol for Biologists

Method
The programs we use in this protocol are Amira 5.2, Adobe Acrobat Pro Extended 9.3, Adobe 
Reader 9.3 and Adobe Illustrator CS4. From here on we will refer to these programs as Amira, 
Acrobat, Adobe Reader and Illustrator, respectively. Furthermore, we will refer to the 3D ob-
ject as object (e.g. a 3D reconstruction of a heart) and the parts this object is composed of as 
structure(s) (e.g. myocardium and lumen), both in Amira and Acrobat. The protocol assumes 
that the user is already familiar with creating 3D reconstructions. Although this protocol starts 
with a 3D reconstruction created in Amira, it can be adapted for other 3D visualisation pro-
grams. 
The protocol consists of two parts. Firstly, a basic protocol describes how to embed a 3D surface 
reconstruction from Amira into a pdf. It describes how to configure Amira and Acrobat and how 
to properly export the 3D surfaces from Amira into a pdf. This pdf can then be saved as a basic 
3D-pdf (Fig. S2) and the embedded 3D surface (we will refer to it as object) can be handled 
interactively using the Adobe Reader user interface (Fig. S1).
The second part of the protocol describes advanced steps requiring a little more computer and 
scripting expertise. This part describes five (independent) additions; 1) creating views and anno-
tations of the object, 2) applying layout to the design, 3) adding buttons, hyperlinks and 4) scripts 
for interaction and functionality; and 5) preparing and displaying cross sections. A pdf containing 
these additional steps will be referred to as an advanced pdf (Fig. S3).
Finally, we would like to note that possible updates to the protocols and scripts described herein 
will be made available at the download page of http://3d.hfrc.nl. 
Please refer to the main publication when a protocol or script described herein has been applied.

Basic protocol
Configure Acrobat

•	 Start Acrobat and open the 3D Capture window by selecting File > Create PDF > From 
3D Capture from the File menu. 

•	 Start Amira and load and display a simple surface. Select the Amira Viewer window and 
press the Print Screen button on the keyboard, whereupon Acrobat will display a popup 
asking if the user wants to enable capturing from Amira. 

•	 Click ‘yes’ and restart both Amira and Acrobat.
•	 Reload and display the simple surface again in Amira, select the Amira Viewer window 

and initiate a capture once more by pressing Print Screen.  
•	 In Acrobat; in the 3D Capture Settings (which only appears the first time)

 ‐ Verify that Enable 3D Capture for this application is checked
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 ‐ Under the OpenGL tab, set the Capture units to those used in Amira. (Unfortunately, 
it seems that micrometers are not properly shown as units in Acrobat, but an update 
might solve this).

 
•	 In the Acrobat 3D Conversion dialogue;

 ‐ Under the General tab;
* Set Default Background Color to white (or another suitable flavour).
* Set Default Lighting to ‘CAD Optimized lights’.
* Set Default Rendering Style to ‘Solid’.
* Set Default Animation Style to ‘None’.
* Uncheck Add default views.

 ‐ Under the Document tab, 
* Set the Page Setup to A4, Landscape

 ‐ Under the Optimize tab,
* Set the 3D format in PDF to ‘U3D ECMA 3’.
* Set U3D: Mesh Quality to 50% 

 ‐ Save these 3D Conversion Settings as default presets for capture from Amira by clicking 
the ‘+’ button. (e.g. Amira_capture)

Load surface file
Your object should be a 3D surface, stored by Amira as an Amira Surface file (.surf ). As a rule of 
thumb; keep the complexity of the object below 100,000 triangles. If you are not familiar with 
surface simplification, consult the Amira documentation. 

•	 Load your object into Amira,
•	 Connect a SurfaceView to the object.

Prepare the surfaceviewers
The object properties of Amira are problematic, as each structure is dual layered (i.e. has an inner 
and outer surface, each with its own color) and intersections between structures are also exported 
as separate surfaces. This has been solved using a custom script which enables proper export of 
the object. For each structure of the object this script creates a separate surface, makes the inside 
color equal to the outside colour, connects a separate SurfaceViewer with correct render settings 
and renames the surfaces and viewers with correct structure names and numbers.

•	 Verify that the SurfaceView connected to the object is named SurfaceView.
•	 Load (or drag and drop) the script surf2pdf.hx (see supplementary scripts) into Amira.
•	 Hide -or remove- the structures you do not wish to export.

3D capture
•	 Ensure that Acrobat is running.
•	 Ensure that the Amira Viewer is the active window (i.e. selected).
•	 Press the Print Screen button on the keyboard.
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•	 In Acrobat; accept the conversion dialog using the preset for Amira (e.g. Amira_capture), 
which generates a pdf of your 3D object.

Rename structures
The structures need to be renamed as the names assigned to the structures in Amira are lost by 
the capture procedure and reappear in Acrobat as numbers. 

•	 Right click on the object in Acrobat and select Edit in 3D Reviewer, which will start the 
program ‘Adobe 3D Reviewer’ with the object loaded.

•	 On the left panel, expand the object tree till the structure names are shown. These will be 
named M0, M1..Mn and are under Models.

•	 Rename each structure by right clicking on its tree entry and selecting Rename. By 
placing the Amira window adjacent to the Adobe 3D reviewer one can easily refer to the 
original names.

•	 Save the changes by selecting Save back in PDF from the File menu of the Adobe 3D 
Reviewer.

•	 Close Adobe 3D Reviewer and click ‘cancel’ in its save changes dialog.

Save the 3D pdf 
•	 In Acrobat; save the resulting file (by default called LastCapture_<timestamp>.pdf ) 

under an appropriate new name. 
The pdf contains a 3D object and can be opened and viewed in Adobe Reader, the freeware ‘read-
only’ program for Adobe’s portable document format (pdf ). The 3D object can now easily be 
shared with others, but make sure that their version of Adobe Reader is up-to-date.

Interaction tools
For the resulting 3D-pdf, interaction with the object can be done with the default tools imple-
mented in Acrobat and Adobe Reader. By default the object is shown as a static image. Clicking 
on the object will activate the interaction with the object and also show the 3D toolbar with the 
interaction tools (Fig. S1, panel e). These interaction tools enable rotation and resizing of the 3D 
object. If the 3D toolbar is hidden, right-clicking on the object and selecting Tools>Show Toolbar 
will uncover it. Furthermore, right-clicking on the object and selecting Show Model Tree or click-
ing the button (Fig. S1, button 6) will show the model tree containing the structures of the object 
(Fig. S1, g). The tree can be expanded by clicking on the plus symbol and structures therein can 
be made (in)visible by toggling the checkboxes.

Advanced steps
The above basic protocol can be used to generate a simple 3D-pdf of a reconstructed 3D object. 
To obtain an advanced 3D-pdf (Fig. S3) enhancements need to be applied to this basic 3D-
pdf. These enhancements are independent of each other, so a single (or multiple) modification 
-as described below- can be applied, whatever suits the document or paper at hand. The main 
purpose of these enhancements is to present the reader a polished document which is easily and 
intuitively used. By adding annotations and prepared views, the disseminator can better convey 
the insights obtained from the object. Also, functionality and robustness can be added by apply-
ing scripts to buttons and the document itself.
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Views and annotations
Adding views and annotations comes highly recommended, as these are the simplest steps of the 
advanced additions and allow the disseminator to better convey the insights obtained from the 
object.

•	 Views can be added and managed in the model tree (Fig. S1, panel g). The model tree 
can be opened in multiple ways; right clicking on the activated object and selecting the 
Show Model Tree or pressing on the Show Model Tree button (Fig. S1, button 6)

•	 Position the object interactively into a required view
•	 Once a suitable view has been set up, pressing the Create View button (Fig. S1, button 8) 

will add a view to the Model Tree. The View panel also contains buttons to delete views, 
or to set a default view (i.e. the view that is set upon opening the document).

Adding annotations to the object is possible -as of Acrobat version 9.1-. This annotation of struc-
tures should not be confused with adding annotations to the document (e.g. sticky note, callout 
tool, Text Box tool). Annotating the 3D object is just to identify structures.

•	 Add Annotations using the Add 3D Comment option of the 3D toolbar. By default, the 
toolbar is shown at the top of the object, or you can select these tools by right clicking 
on the object and selecting tools

•	 You can set the colour of the comments in (Edit > Preferences > Measuring (3D) > 3D 
Measuring Line Colour).

Layout
To apply or create the content for your layout, the vector graphics editor Illustrator is the ideal 
application to use, as vector graphics keep the file size to a minimum. Furthermore, Illustrator 
belongs to the same software suite which avoids compatibility problems. The first thing to con-
sider is what the appropriate size and ratio for you document should be. This is dependent of 
your end product, e.g. A4 when you want to include the object in a standard ‘paper’ document or 
a 4:3 ratio if the document is meant to snugly fit a digital presentation, as the majority of displays 
and beamers use a 4:3 ratio (note that 16:9 is steadily advancing).
We recommend to include the following content; a header, a placeholder for the 3D object and 
buttons to either interact with the 3D object or to serve as hyperlinks to the accompanying paper 
and affiliated institute. We recommend to design the buttons yourself, as opposed of creating 
them in Acrobat because this keeps design separated from function. The functional part of hy-
perlinks and buttons is discussed in the next chapter. 
Start by creating a new file in Illustrator: File > New and set the page to its appropriate size and 
aspect ratio.

•	 Create the minimum graphics; 
 ‐ A clear header with a description of the object(s). 
 ‐ A simple rectangle which will function as a placeholder for the 3D object.
 ‐ Graphics for buttons and hyperlinks to the original paper and your department’s or 

group’s website.
•	 Once finished with the design, save the file as a design-pdf. 
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 ‐ Set the Adobe PDF Preset in the save dialogue to Smallest File Size, which will decrease 
the file size and remove the layer structure of Illustrator which is currently not fully 
compatible with 3D objects. 

After having created this design-pdf, the 3D object from the basic-pdf created with the basic 
protocol needs to be pasted into this design;

•	 Open both the basic 3D-pdf and the design-pdf files in Acrobat 
•	 Use the Select Object Tool (Fig. S1, button 2) under the Advanced Editing Tools to select 

and copy  (ctrl+c) the 3D object
•	 Paste (ctrl+v) the 3D object into the design pdf.
•	 Position the object into your placeholder. Positioning can be improved by turning off 

Snap to Grid or by using guides. 
•	 Minor changes to aspects of the design or fields of text can be done using the TouchUp 

Object tool (Fig. S1, button 4) under the Advanced Editing Tools. Using this tool, items 
can be selected and nudged or moved into the right direction.

Supplemental Figure S1.

 Overview of the 3D pdf as viewed in Acrobat. The myriad of panels (purple; alfabetized) and tools (black; num-
bered) are: a) Acrobat toolbar. b) Acrobat advanced editing tools (Not available in the Adobe Reader) c) Opened 
document d) 3D object embedded in the document. e) 3D toolbar to edit or interact with 3D object (Adobe 
Reader does not have the edit tools). f ) Custom panel within the document containing custom buttons created 
with Acrobat and Illustrator as described in the advanced segment. g) Model Tree navigation panel to interact with 
the 3d object. 1) Select tool 2) Select Object tool 3) Button tool 4) TouchUp object tool 5) Add 3D Comment 
button 6 and 7) Show Model Tree button 8) Create View button.
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•	 Major changes can be achieved, by right-clicking the selected objects and selecting Edit 
Object to open Illustrator which allows more degrees of freedom in editing. Saving the 
edited item will automatically save the changes back into the 3D-pdf opened in Acrobat.  

•	 Save the resulting 3D-pdf. 
The 3D-pdf now contains your custom graphics from Illustrator and a 3D object from Acrobat.
Note: Never load the 3D-pdf in its entirety into Illustrator because Illustrator is not able to cor-
rectly handle and save the embedded 3D object within, which will be lost.

Buttons and hyperlinks
The functionality of the 3D-pdfs can be enhanced with buttons. Storing specific views and/or 
hiding specific structures can also be achieved using the default interaction tools. However, to 
enhance and simplify interacting with the objects, buttons with similar -or more complex- func-
tionality can be created and behaviour can be added by scripts.

•	 Using Illustrator, add the appropriate button graphics to your document as described in 
the layout chapter.

•	 Using Acrobat, overlay these graphics with buttons using the Button Tool (Fig. S1, 
button 3). The buttons can then be edited using the Button Tool or the Select Object Tool 
(Fig. S1, button 2). Both tools can also be found under Tools > Advanced Editing in the 
menu.

•	 Assign a proper name to each button, either by right clicking on it using the Button Tool 
or use the Select Object Tool and select Properties or Rename Field.

•	 Go to the Appearance tab in Properties (see above) and hide the superimposed buttons by 
setting their colour to ‘none’. 

After setting up your buttons, assign functionality to them, either by what is provided by Acrobat 
or assign custom scripts to them (see Scripting chapter below). 

•	 To make a button link to a website, i.e. hyperlink; 
 ‐ Select the button using the Select Object tool or Button tool
 ‐ Right-click the button and select Properties, then the Actions tab

* Set the Select Trigger to Mouse up
* Set Select Action to Open a web link and press Add...
* Enter the URL / link to the site

Scripting
Scripting is the most complicated part of the enhancements, and although the examples pro-
vided in this paper are not very complicated, programming experience is highly recommended. 
Documentation on how to create scripts can be found at http://www.adobe.com/devnet/acrobat/
javascript.html and code regarding Javascript and Acrobat 3d can be found at http://www.adobe.
com/devnet/acrobat/javascript_acrobt_3d.html.
In a 3D-pdf containing a 3D object, JavaScript can be applied at two levels; the document level 
and the object level. The only piece of script we applied at the object level in the example pdf is 
the disable select script. By default, clicking on a structure selects it and renders it in red, which is 
unwanted, as we use colours to convey the different types of structures in the object. The ‘disable 
select’ script will remove this behaviour from all structures in the object. The other script will 
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be applied at the document level, which allows this script to be called (i.e. used) by all buttons. 
An overview of every script at the document level can be found on the Acrobat menu Advanced 
> Document Processing > Edit all Javascript. In our published documents, we mainly used func-
tions to hide, show and make structures transparent. The implementation of these functions to 
buttons is what we will describe here. By using functions, you will centralize the functionality of 
your document which makes it easier to change this functionality or duplicate it. Furthermore, 
the functions (if properly coded) are page independent which is very important as it will ensure 
that the buttons will keep working irrespective of changes in page numbering / order. (e.g. by 
appending the 3D-pdf to a publication or after combining multiple 3D-pdf files into one pdf )

•	 To prevent the default select behaviour, load the disable_select.js file into the object. 
 ‐ Edit the 3D object properties by right-clicking on the object and select Properties

* under the 3D tab select browse to load the script.
•	 To add the custom functions go to Advanced > Document Processing > Document 

JavaScripts
 ‐ enter a new script name, e.g. ‘custom_functions’, push the Add button, and replace the 

existing (empty) function with the supplemented code (see custom_functions.txt in 
the supplementary scripts).

•	 The functions pasted in the document script can now be called by using the buttons (or 
any other event). To apply a function to a button:
 ‐ Select the button using the Select Object tool or Button tool
 ‐ Right-click the button and select Properties, then the Actions tab

* Set the Select Trigger to Mouse up
* Set Select Action to Run a Javascript and press Add...
* In the Javascript Editor type the call to the appropriate function (or write custom 

code), such as hide(“Lumen”); to hide the structure named Lumen. Make sure that 
the names of the structures in the model tree match those written within quotation 
marks (note that Javascript is case-sensitive). 

Cross sections
A SurfaceCut can be used to clip a part of the object in Amira. This clipping cannot be trans-
ferred to Acrobat, but after preparation in Amira, the SurfaceCut(s) can be exported to Acrobat 
and visualized in the 3D-pdf, even with clipping. 

•	 Load the .surf file into Amira, connect a SurfaceView
•	 Follow the steps Prepare the surfaceviewers from the basic protocol
•	 Connect one (or more) SurfaceCut(s) to the .surf file and choose the desired orientation 
•	 Follow the steps 3D Capture  from the basic protocol

The structures and cuts should now be present in a pdf. Check this in the structure tree. The 
structures and cuts should be separate groups. In rare cases, the model tree is built incorrectly, so 
verify this. If it is not correct; close and delete the pdf file. In Amira; remove the SurfaceCut(s),  
hide and subsequently unhide the structures, recreate the SurfaceCut(s) and repeat the 3D cap-
ture step. 
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When all structures and cuts are present in the captured pdf, it can be further processed in Ac-
robat.

•	 Write down the numeric codes of the structures and cuts (M0-Mn) and the structure 
names to which they should be renamed

•	 Follow the steps Rename structures from the basic protocol
•	 The structure names of the first cut should be renamed to <structurename>_cut1 

for the supplied ‘custom_functions’ script to work correctly. Repeat this for every 
additional cut, while incrementing the number (i.e. the second cut should be renamed to 
<structurename>_cut2)

•	 Edit the “custom_functions” script (see Scripting step) to change the number of cuts 
(noc) variable (e.g. 2 cuts; change “noc = 0” to “noc = 2”)

•	 Emulate the clipping of SurfaceCuts in Acrobat by;
 ‐ Hide everything (uncheck in the model tree)
 ‐ Unhide the cut you wish to show and rotate it so that the cut is perpendicular to your 

line of sight. 
 ‐ Click on the Toggle Cross Section button (Fig. S1, button 9)
 ‐ Click on the Cross section properties (the small triangle next to the Cross Section button)
 ‐ In the cross section Properties

* Check Enable Cross Section
* Uncheck Show Intersections
* Uncheck Show Cutting Plane
* Click on Align to 3 Points to align the orientation of the cross section of Acrobat 

with the cut produced in Amira. For this you need to select three points on the 
visible structures of this cut 

* unhide the object structures (check in the model tree)
* (un)check flip, depending on the half you wish to show
* Nudge the Offset to +0.1% or -0.1%, depending on the direction of the cut. 

Sometimes the angles are correctly calculated, but the offset is not. Try and nudge 
the offset dragger until you find the correct spot.

* Drag the cross section Properties interface to the side (or close it)
 ‐ Unhide the structures you wish to show and / or hide the structures within the cut 
 ‐ Press on the Create View button to store this viewpoint, make sure that the Camera 

Properties, Cross section information and Node visibility are checked
•	 Repeat the above step for each cut (or inverse cut)
•	 Link the views to buttons as described in the scripting part

Supplementary scripts (see supplementary_scripts.zip on CD)
•	 surf2pdf.hx
•	 disable_select.js
•	 custom_functions.txt
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Appendix 2: Methods of TRACTS
Normalized error measure 
The difference between the section found by TRACTS and the position of the expected section 
is measured by the normalized fit error. This error measure takes into account both the angle 
between the planes of the sections and the average distance of the centres of mass of each section 
to the other section. 
Let S and T be two sections and let V be the plane through S and W the plane through T. Then 
we define the first component of the fit error as follows.

where α is the angle between planes V (trough section S) and W (trough section T).
For the second component, we use the fact that the distance of a point x to a plane V can be com-
puted by |nV∙(x-aV)|, where nV  is the unit normal of the plane V and  aV is an arbitrary point on 
the plane V. (See Weisstein, E.W. "Point-Plane Distance." From MathWorld--A Wolfram Web 
Resource. http://mathworld.wolfram.com/Point-PlaneDistance.html). The distance between 
two sections is defined as 

where  nV is the unit normal of the plane V,  mT is the centre of mass of section T,  aV is arbitrary 
point on the plane V, and nW, mS and aW are defined analogously.
To make Dp equal in weight to D∠(S,T), which ranges from 0 (at 0 degrees) to 1 (at an angle of 90 
degrees),   is divided by the size of the reference model (3) before both components are combined 
into the fit error (4). 

where Ax  is the length of the x-axis of reference model M, and Ay and Az are defined analogously.
Fe(S,T)is normalized to be 100 at maximum

Pre-processing of input section
Before an input section can be compared to the reference model, pre-processing of this image has 
to take place. After input into TRACTS a bounding box is fitted around the segmented heart 
and the image is cropped. The resulting binary image is rotated in 32 steps and mirrored at each 
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position. The resulting 64 images are processed like the pre-computed reference sections (refer-
ence model images): determine its size, resize to 128x128 pixels, determine features, compute 
contour, and distance transform. These images are then used for fitting to the virtual sections of 
the reference model.

Similarity metric
The similarity between the input image and the cross section from the reference model (reference 
section) is given by a similarity measure that is based on the mean Euclidean distance between 
the inner and outer contours of the heart in the input section to the contours in reference section, 
and vice versa. The contour is considered to be a good representation of the shape of the heart. 
To compute this similarity measure the input section and the reference sections are all resized 
to 128x128 pixels from which the contour is derived. From these contour images a distance 
transformed image is generated. The pixel values in these distance transformed images represent 
the Euclidean distance to the heart contour. To find the similarity between the two contours, 
the distance transformed image of one contour image is masked by the contour of the other im-
age and vice-versa. The mean distance is determined from the remaining distance values in the 
contour masks. By using the sum of both average distance values the resulting similarity metric 
is symmetric, that is, the resulting value would be the same when comparing a reference section 
to an input section and the other way around. 

Reference model images
The database of cross sections of the reference model contains sections that are generated at every 
second voxel over the three main axes of the reference model. At every position 64 cross-sections 
are computed with a different combination of tilting angle and tilting direction. The tilting angle 
ranges from 0 to 40 degrees (in steps of 10 degrees) and the number of tilting directions increases 
with each increment of the tilting angle. The number of tilting directions is determined in such 
a way that the normal vectors of the resulting sections are distributed approximately uniformly 
in 3D space. The small, nearly cubic, voxels of an episopic reconstruction are such that cross sec-
tions in all directions can be made without loss of morphology. All model sections are converted 
to a pixel size equal to the original x and y resolution of the model. Only those sections contain-
ing over 20 pixels of myocardium are used. Every section is cropped to the bounding box around 
the heart. The size of this bounding box is determined and stored. Then the model images are 
resized to a standard size of 128x128 pixels. The contours of the heart in those resized images 
are determined and their distance transformed images are computed. Both the contour and the 
distance transformed images are stored. For the E11.5 reference model this results in 32813 im-
age pairs stored in the database. The positional and size information are stored in an index table.

Selection of images on features 
To reduce computation time, not all sections from the reference model are compared to the input 
section. Initially only those that are similar in size are selected. The size difference between input 
and reference section may not exceed 20%, which is based on expert knowledge that embryonic 
hearts never differ over 20% in size at the same developmental stage. In an attempt to exclude the 
misplaced sections additional features were implemented. Since selection based on these features 
results in a lower number of distance transform-based comparisons, it has the added benefit of 
making the program faster. The decision which features to use is based on an analysis in which 
experts did a visual assessment of input sections and the recovered reference sections (de Boer et 
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al., 2007). Features that exclude the unsatisfactory fit results without affecting the well fitted im-
ages were preferred. Several potential features were tested, and three of these were selected based 
on their individual performance. These features were (1) centre of mass, (2) overall tissue density 
and (3) regional tissue density. Thresholds for each of these features where determined after some 
experimentation and in consultation with experts. All these features are based on the myocardial 
area of a cross section.
1. The centre of mass feature is defined as the average position of the myocardial tissue of a 

cross section. This feature was used to avoid that images with a very different tissue distribu-
tion are matched. 

2. The overall tissue density is measured by counting the number of pixels containing tissue in 
the resized images. The density feature was applied because the basic program regularly fitted 
sections with a large amount of tissue, for instance a section containing a thick ventricular 
wall, to sections with a small number of tissue pixels, for instance a section containing only 
a thin atrial wall. Such a difference in wall thickness is reflected by the part of the section 
containing tissue. 

3. The last feature uses a regional tissue density measure. For this feature the density in the four 
corners of every section is measured. To compensate for both technical and biological defor-
mations of the tissue, the density measurement of the input sections is done by moving the 
measurement areas 6 pixels around each quarter of the image and selecting the minimum 
and maximum tissue area of each quarter.

Reference
de Boer,B.A., Ruijter,J.M., and Voorbaak,F.P.J.M. (2007). Towards the automatic registration of histological sec-
tions into a 3D reference model. In BNAIC'07. Proceedings of the 19th Belgian-Dutch Conference on Artificial 
Intelligence, Utrecht:  5-6 November 2007. (ed. Dastani,M.M. and de Jong,E.), pp. 41-48.
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Appendix 3: Mathematics of cell cycle lengths 
derived from labelling indices
The fraction labelled cells (F) is determined by the exposure time and the unknown lengths of 
the S-phase and the cell cycle , TS and TC, respectively (Sanders et al., 1993). Using two different 
thymidine analogues (IdU and CldU) and two different exposure times these unknowns can be 
derived.

Derivation of the equation for TC

According to the equation given by Sanders and co-workers (Sanders et al., 1993) the labelling 
fraction after CldU (FCl) exposure is given by:

in which TCl is the exposure time to CldU. Eq. [1] can be solved for TS:

Similarly, the exposure to IdU results in the labelling fraction (FI) of:

Substitution of Eq. [2] into Eq. [3] gives:

which can be solved for TC:

With Eq. [6] it is easy to see that an incorporation lag (TL) has no effect on observed TC, because 
such a lag affects both exposure times in the same way:
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The labelling fraction after exposure to CldU for a population with a growth fraction (FD) is 
given by Equation 1a (Nowakowski et al., 1989; Sanders et al., 1993). This equation is used to 
derive the equation for TC, including the growth fraction (the equations are in the same order 
as above):

which can be solved for TS∙FD:

The similar exposure to IdU results in the labelling fraction of:

Substitution of Eq. [2a] into Eq. [3a] results in:

which can be simplified to:

Equation 5a shows that the observed TC of a population, i.e. the population doubling time, is the 
cell cycle length of the dividing cells multiplied by the growth fraction of the population.

Derivation of the equation for TS
The equation given by Sanders and co-workers (Sanders et al., 1993) states that the labelling 
index after exposure to CldU is given by:

which, solved for TC reads like:
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Similarly the exposure to IdU results in the labelling fraction of:

Substitution of Eq. [8] in Eq. [9] then gives

This can be rearranged to give the following equation for TS:

When the growth fraction (FD), which is the fraction of cells that is dividing is constant, TS is 
derived as follows (the equations are in the same order as above):

In Eq. [10a] it is clear that FD disappears from the equation. Therefore, the growth fraction has 
no influence on the calculation of the S-phase length.
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The bias due to the insertion a lag time (TL) between injection and incorporation, on determined 
S-phase is equal to the incorporation lag. With the definition of TS in Eq. [11] and a lag phase 
TL, the real TS can be defined as

which after re-arrangement reads as:

The first part on the right is the TS that will be observed because the presence of a lag phase is 
unknown, the second part simplifies to TL:

Equation [14] shows that the observed S-phase length is too short when an incorporation lag is 
present. The length of this lag has to be added to obtain the real S-phase length.

Division of labelled cells
When the exposure time to the first label (IdU) is longer than TG2 + TM, cells that were labelled 
during TS reach the end of TM and will divide. In that case, the fraction of labelled cells at the 
moment of fixation that was defined as FI, is also equal to the fraction of cells in S, G2 and M 
(FS, FG2 and FM, respectively) plus a fraction of cells (Fdivision) that results from the cell division:

or

With

and Eq. [3] for FI, Fdivision (Eq. [16]) can be re-written as
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which simplifies to

Equation [19] shows that for exposure times (TI) longer than the sum of TG2 and TM, an extra 
group of dividing cells is counted and added to FI. This will increase the denominator in Eq. [5] 
and the observed TC will thus be underestimated. Therefore, the exposure time should be kept 
shorter than the sum of TG2 and TM.
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